UPDATE4: NHTSA Investigation interview -- WMA5 update removed Innodrive on 2020 4S. Later, engine dies on way to getting it fixed.

Chris8536

Well-Known Member
First Name
Chris
Joined
Apr 10, 2021
Messages
206
Reaction score
155
Location
San Francisco
Vehicles
Taycan 4S
Country flag
Just put in for the update last week and got it back Friday. Seemed everything went smoothly and I drove it home with no issues. After taking it up with the family to Sonoma I noticed innodrive was no longer responding. No icons no settings no anything. When I press the innodrive activation button on the wand I got a broken screen on the center dash with half functionality showing. After that I would get random driver warnings to put my hands on the wheel which was very worrisome since an invasive driving feature was snapping on and off without my control. After trying a bit more I noticed passive lane keep, cruise control and active cruise were all broken too. Working sporadically and turning on without my control.

I reached out to my contact at my Porsche dealer but haven’t heard back yet. I’m guessing it was somehow coded off with the update as my settings for it are gone. I also noticed other complaining innodrive was not feature complete after the update and missing active lane keep.

Porsche needs to understand that an update that removes a 5k feature is not ok. And it’s downright dangerous when it changes the driving functionality of the car.
Advertisement

 
Last edited:

Kingske

Well-Known Member
First Name
Frank
Joined
Jun 6, 2020
Messages
1,233
Reaction score
1,391
Location
New Jersey, USA
Vehicles
2020 Porsche Taycan 4S, 2014 BMW 3 GT
Country flag
@TomC , I saw your angry emoji in the previous post. Any further news on your post-update 12V issue?
 

TomC

Well-Known Member
First Name
Tom
Joined
Nov 28, 2020
Messages
145
Reaction score
344
Location
Cambridge, England
Vehicles
MY2022 Taycan Turbo S
Country flag
@TomC , I saw your angry emoji in the previous post. Any further news on your post-update 12V issue?
Nothing more than my last post here: https://www.taycanforum.com/forum/threads/locked-out.3916/page-2

They’re expecting the new battery sometime next week. As angry as I am (mostly with the service, the issue itself is more disappointing, as things can obviously go wrong), all that driving another car for a week has proven is just how good the Taycan is. I’m still going to get a MY2022 Turbo S and just cross my fingers they start to make it more reliable.
 

Kingske

Well-Known Member
First Name
Frank
Joined
Jun 6, 2020
Messages
1,233
Reaction score
1,391
Location
New Jersey, USA
Vehicles
2020 Porsche Taycan 4S, 2014 BMW 3 GT
Country flag
Nothing more than my last post here: https://www.taycanforum.com/forum/threads/locked-out.3916/page-2

They’re expecting the new battery sometime next week. As angry as I am (mostly with the service, the issue itself is more disappointing, as things can obviously go wrong), all that driving another car for a week has proven is just how good the Taycan is. I’m still going to get a MY2022 Turbo S and just cross my fingers they start to make it more reliable.
True pioneering spirit!
 

Arjan_

Well-Known Member
First Name
Arjan
Joined
Apr 26, 2020
Messages
89
Reaction score
81
Location
Nederland
Vehicles
BMW M3, Porsche Taycan Turbo S
Country flag
Just put in for the update last week and got it back Friday. Seemed everything went smoothly and I drove it home with no issues. After taking it up with the family to Sonoma I noticed innodrive was no longer responding. No icons no settings no anything. When I press the innodrive activation button on the wand I got a broken screen on the center dash with half functionality showing. After that I would get random driver warnings to put my hands on the wheel which was very worrisome since an invasive driving feature was snapping on and off without my control. After trying a bit more I noticed passive lane keep, cruise control and active cruise were all broken too. Working sporadically and turning on without my control.

I reached out to my contact at Porsche Marin but haven’t heard back yet. I’m guessing it was somehow coded off with the update as my settings for it are gone. I also noticed other complaining innodrive was not feature complete after the update and missing active lane keep.

Porsche needs to understand that an update that removes a 5k feature is not ok. And it’s downright dangerous when it changes the driving functionality of the car.
I lost active lane keeping after the update last week (Innodrive is still there and is not broken). Also I got phantom warnings from the car. Today for instance while driving without innodrive I got a warning to put my hands on the wheel.
 
OP
OP

Chris8536

Well-Known Member
First Name
Chris
Joined
Apr 10, 2021
Messages
206
Reaction score
155
Location
San Francisco
Vehicles
Taycan 4S
Country flag
I lost active lane keeping after the update last week (Innodrive is still there and is not broken). Also I got phantom warnings from the car. Today for instance while driving without innodrive I got a warning to put my hands on the wheel.
Same thing except innodrive is removed from my settings. Odd that you have activelane keep as that essentially is innodrive
 

Arjan_

Well-Known Member
First Name
Arjan
Joined
Apr 26, 2020
Messages
89
Reaction score
81
Location
Nederland
Vehicles
BMW M3, Porsche Taycan Turbo S
Country flag
Same thing except innodrive is removed from my settings. Odd that you have activelane keep as that essentially is innodrive
I lost active lane keeping but still have innodrive
 

TaycanAZ

Member
First Name
JD
Joined
Oct 7, 2019
Messages
9
Reaction score
4
Location
Phoenix AZ
Vehicles
Boxster, Panamera, 911 C2S
Country flag
Just put in for the update last week and got it back Friday. Seemed everything went smoothly and I drove it home with no issues. After taking it up with the family to Sonoma I noticed innodrive was no longer responding. No icons no settings no anything. When I press the innodrive activation button on the wand I got a broken screen on the center dash with half functionality showing. After that I would get random driver warnings to put my hands on the wheel which was very worrisome since an invasive driving feature was snapping on and off without my control. After trying a bit more I noticed passive lane keep, cruise control and active cruise were all broken too. Working sporadically and turning on without my control.

I reached out to my contact at Porsche Marin but haven’t heard back yet. I’m guessing it was somehow coded off with the update as my settings for it are gone. I also noticed other complaining innodrive was not feature complete after the update and missing active lane keep.

Porsche needs to understand that an update that removes a 5k feature is not ok. And it’s downright dangerous when it changes the driving functionality of the car.
I Have the same issue on 2020 Taycan Turbo.
 

f02kbf

Member
First Name
Eric
Joined
Jun 27, 2020
Messages
13
Reaction score
15
Location
New York, NY
Vehicles
Taycan 4S
Country flag
It’s strange but I’m having a similar but dissimilar experience. After the update innodrive is still in the menu but when I activate it, it does not appear on the display. It still says driver’s assistance off and the set speed does not display. Oddly, I can tell it’s actually working. The car regulates the speed and stays in the lane. I just have no visual confirmation that it’s enabled or what it’s set to. Dangerous considering at first I didn’t realize it was working until it sped up after the car in front of me changed lanes.
 
OP
OP

Chris8536

Well-Known Member
First Name
Chris
Joined
Apr 10, 2021
Messages
206
Reaction score
155
Location
San Francisco
Vehicles
Taycan 4S
Country flag
Well the Porsche dealer took the car in and had a look at the issue -- I should have noticed something was wrong when they didn't to give me any paperwork or acknowledge looking at it on record.

the WMA5/7 update borked Innodrive and they said Porsche NA knows. However they may send out a patch someday (no promises). I said hey you've removed almost $5k worth of features on my vehicle. He shrugged and said 'you'll have to deal with it. Its still safe to drive.'

This is an interesting situation because on one hand what is the dealer supposed to do, they can't write software there. On the other hand Porsche NA is doing a terrible job of communicating what's going on here. And on the third, most important hand, they've removed a $5k worth of features! What would you do if Full Leather or Sport Chrono was gone when you got it back from the dealer.

Anyone else have any thoughts? Im willing to be patient for a little bit as software is hard, but at the same time I'm not confident Porsche GmB can deal with this.
 
Last edited:

chrisk

Well-Known Member
Joined
Dec 3, 2020
Messages
974
Reaction score
977
Location
California
Vehicles
2020 Taycan 4S
Country flag
Well the Porche dealer took the car in and had a look at the issue -- I should have noticed something was wrong when they refused to give me any paperwork or acknowledge looking at it on record.

the WMA5/7 update borked Innodrive and they said Porsche NA knows. However they may send out a patch someday (no promises). I said hey you've removed almost $5k worth of features on my vehicle. He shrugged and said 'you'll have to deal with it. Its still safe to drive.'

This is an interesting situation because on one hand what is the dealer supposed to do, they can't write software there. On the other hand Porsche NA is doing a terrible job of communicating what's going on here. And on the third, most important hand, they've removed a $5k worths of features! What would you do if Full Leather or Sport Chrono was gone when you got it back from the dealer.

Anyone else have any thoughts? Im willing to be patient for a little bit as software is hard, but at the same time I'm not confident Porsche GmB can deal with this.
This is a safety system and it should work if you paid for it. You need to take your car at any authorized dealer (try a different one) for service and get in writing that it is not working and that they cannot fix. Then if they fail to fix it after 30 days you should invoke the lemon law and get your car replaced with one where the feature works.
If the dealer does not want to check the car in, first talk to the uber Service Manager there and ask them to take the car in and create a case with Porsche NA. If they still don't accept your car, then given send a formal written notice to Porsche NA that their authorized representative does not want to perform warranty repairs for your car and ask them to indicate where you should have your car services per the warranty agreement.
 
Last edited:
OP
OP

Chris8536

Well-Known Member
First Name
Chris
Joined
Apr 10, 2021
Messages
206
Reaction score
155
Location
San Francisco
Vehicles
Taycan 4S
Country flag
Today the Porsche dealer acknowledge the issue after an escalation.

So after the call I was driving home with my family and the engine dies and I have to wrestle it to the side of the road coasting on a dangerous curving stretch of highway 1.
Jesus. F*^&%ing. Christ.

This car is a death trap.
 
  • Wow
Reactions: B61

andrewket

Well-Known Member
First Name
Andrew
Joined
Jan 31, 2021
Messages
542
Reaction score
396
Location
Vienna, VA
Vehicles
21 Taycan Turbo, Tesla Y*2; Prev S,X,3,996TT
Country flag
Today the Porsche dealer acknowledge the issue after an escalation.

So after the call I was driving home with my family and the engine dies and I have to wrestle it to the side of the road coasting on a dangerous curving stretch of highway 1.
Jesus. F*^&%ing. Christ.

This car is a death trap.
Please report it: https://www.nhtsa.gov/
 
Last edited:

chrisk

Well-Known Member
Joined
Dec 3, 2020
Messages
974
Reaction score
977
Location
California
Vehicles
2020 Taycan 4S
Country flag
Today the Porsche dealer acknowledge the issue after an escalation.

So after the call I was driving home with my family and the engine dies and I have to wrestle it to the side of the road coasting on a dangerous curving stretch of highway 1.
Jesus. F*^&%ing. Christ.

This car is a death trap.
Sounds the same as reported by at least 4 members in other threads. Probably a newly introduced bug in WMA5 update.
Did turning it off/on resolve the issue (until it happens again)?

https://www.taycanforum.com/forum/t...er-in-the-outside-lane.2950/page-5#post-67510

https://www.taycanforum.com/forum/threads/losing-power-issue.4889/
 
Advertisement

 
SRM Autosports
Advertisement
Top