Using Car Scanner App to log, understand and diagnose Taycan

rs38

Well-Known Member
Joined
Nov 16, 2020
Threads
6
Messages
327
Reaction score
277
Location
west germany
Vehicles
taycan,gt2,i8
Country flag
https://play.google.com/store/apps/details?id=com.ovz.carscanner

https://itunes.apple.com/app/car-scanner-elm-obd2/id1259933623?mt=8


Pro Version is not a must, but worth it, no ads and the ability to export logs to analyse further e.g. with Jupyter

car scanner app.jpg


This is one of the better known OBD2 apps and I helped the author with making it work with the Taycan and provided some reverse engineered diag channels (some call it sensors or PIDs).

I tested at least 5 different dongles, BLE Dongles are much easier to handle and must have for IOS.

please test it and share some impression, screenshots, data, bugs, ideas and dashboard designs!


short howto:

in settings, choose your BT device, then select Porsche, Taycan profile and ready to connect and play around.

latest find of some error codes that the app cannot translate:
https://static.nhtsa.gov/odi/tsbs/2022/MC-10215441-0001.pdf

 
Last edited:

Dee

Well-Known Member
First Name
Dee
Joined
Dec 14, 2018
Threads
57
Messages
2,119
Reaction score
2,415
Location
The Netherlands
Vehicles
A lot
First of all, the SoH is way off imho.
I have 90,42% at 25000km (MY20).
No fast charging, only charge to 85% max.
Next week I'm gonna test if charging to 100% makes a difference.
I talked to another Taycan owner and he reports SoH 91,44% at 18000km (MY22), also charged to 80-90% max.
He's going in for the PCM update next week and will ask to check the SoH of the battery, maybe the reading is different.

Second, in the dashboard it says "Reboot MMI":
Screenshot_20220726-153754.png

But unfortunately that doesn't work.

So, I went to "All sensors":
Screenshot_20220729-081121.png

And found the [5F.MMI] Reboot Multimedia System.
Pressed it, [Action] Yes.
The PCM rebooted so that command works.
I went back to the dashboard and double tapped on the middle tile again, try to find the [5F.MMI] Reboot Multimedia System in the list to reassign it but it's not even on the list.
That's why it's not working from the dashboard.

Then I send a log to the developer but he doesn't know either.
It would be nice to have the tile working so @rs38 it would be nice if you can find what is wrong with the list in dashboard mode...
I even did a search within the list, both "water" and "Multimedia".
"Water" gave multiple results while "multimedia" didn't so it's defenately not there (including typos).
 
Last edited:

Dee

Well-Known Member
First Name
Dee
Joined
Dec 14, 2018
Threads
57
Messages
2,119
Reaction score
2,415
Location
The Netherlands
Vehicles
A lot
A good OBD dongel is essential.
Please read this: https://www.carscanner.info/choosing-obdii-adapter/

I'm using an old (fake?) ELM327 adapter, maybe that's the reason the readings aren't accurate and the app is acting wierd.
I've ordered a Vgate iCar Pro to see if that makes a difference.
Will report back (both on 100% charging on the ELM327 and with the new Vgate adapter).
 


Scandinavian

Well-Known Member
First Name
Peter
Joined
Nov 3, 2019
Threads
29
Messages
1,743
Reaction score
1,437
Location
France
Vehicles
Taycan T, Tesla M3P, Aston Martin DB9, Porsche 996 C4 Cab
Country flag
First of all, the SoH is way off imho.
I have 90,42% at 25000km (MY20).
No fast charging, only charge to 85% max.
Next week I'm gonna test if charging to 100% makes a difference.
Did you get to test to charge yo 100%? I also have tried the app with a bluetooth OBDII reader. Just below 90% as well? Normally charge to 80 -85% on AC but on road trips I use HPC. Only charged to
100% a few times before long drives.

630C655B-E2E9-48E2-AD03-B40227E2C205.jpeg


MY 2020 Turbo.
 

Dee

Well-Known Member
First Name
Dee
Joined
Dec 14, 2018
Threads
57
Messages
2,119
Reaction score
2,415
Location
The Netherlands
Vehicles
A lot
Did you get to test to charge yo 100%? I also have tried the app with a bluetooth OBDII reader. Just below 90% as well? Normally charge to 80 -85% on AC but on road trips I use HPC. Only charged to
100% a few times before long drives.

630C655B-E2E9-48E2-AD03-B40227E2C205.jpeg


MY 2020 Turbo.
Yes but I want to charge to 100% multiple times.
Meanwhile I wait for my new adapter to arrive.
But seeing your SoH% I don't think it'll make a difference.
What adapter are you using?
How many kms do you have?
 
OP
OP
rs38

rs38

Well-Known Member
Joined
Nov 16, 2020
Threads
6
Messages
327
Reaction score
277
Location
west germany
Vehicles
taycan,gt2,i8
Country flag
SoH Just below 90% as well? Normally charge to 80 -85% on AC but on road trips I use HPC. Only charged to
100% a few times before long drives.
keep in mind, this SoH reading is exactly the same as shown in the PIWIS3 / PTG3 Tester at Porsche but with more decimals and Porsche calls it "fast reading".
Slow and more precise reading would mean to discharge the battery for a certain range of SoC.
I didn't check this procedure yet.

I already have seen 10-15 readings from 88% to 99.2% (new Taycans with 300km!! up to 39000km ) SoH.
Lower readings are usually MJ20 and also seem to correlate with charging by solar AC which can be many sessions because of the 6A cut-off.

The SoH value changes a bit in both directions. Most car's seem to be around 94% and are worse in winter.

There are many more details hidden in the ECUs but it's quite hard to provide more definitions and communicate with the car scanner author. Not speaking of the many many days of work to find and reverse all that stuff as a lonely rider 🤠

For example there is a diag value like "kWh stored in battery" which reads as ~81000Wh for my car.
Also the BMS saves kind of SoH and Ah per cell for every month or so.
 
  • Like
Reactions: Dee


Dee

Well-Known Member
First Name
Dee
Joined
Dec 14, 2018
Threads
57
Messages
2,119
Reaction score
2,415
Location
The Netherlands
Vehicles
A lot
The SoH value changes a bit in both directions. Most car's seem to be around 94% and are worse in winter
That's why it's inaccurate cuz SoH% shouldn't be changing, neither by temperature nor SoC%...
It's about the kWh that the battery stores and the nominal capacity.
I'm curious if I can make a change by changing my charge habits...
If so, the sensor is not the correct one to look at to provide the actual SoH%.
 

Scandinavian

Well-Known Member
First Name
Peter
Joined
Nov 3, 2019
Threads
29
Messages
1,743
Reaction score
1,437
Location
France
Vehicles
Taycan T, Tesla M3P, Aston Martin DB9, Porsche 996 C4 Cab
Country flag
Yes but I want to charge to 100% multiple times.
Meanwhile I wait for my new adapter to arrive.
But seeing your SoH% I don't think it'll make a difference.
What adapter are you using?
How many kms do you have?
I have 28650 km on the clock now

I use the OBDLink MX+ With bluetooth and Apple iOS. Seems to work fine but surprised still at the low value for SoH.

Once holidays are over I will do a range test by driving the battery from 100% to about5% and compre the values.

Still have not heard anything about the uPdate here.
 
  • Like
Reactions: Dee

Dee

Well-Known Member
First Name
Dee
Joined
Dec 14, 2018
Threads
57
Messages
2,119
Reaction score
2,415
Location
The Netherlands
Vehicles
A lot
I just tried the Vgate iCar Pro but SoH% results are the same.
So my old ELM327 does exactly the same as this new adapter.
Only advantage is that the Vgate is much smaller so I'll leave it in.

I use the ELM327 for my RX8 which has a built-in tablet with the Torque app and Racing Meter dashboard:

IMG_20220805_131158461.jpg


IMG_20220805_130959697.jpg

Shift lights work, also the s/w gear indicator (it's in neutral now, based on kph/rpm). 🥳
 
Last edited:

Dee

Well-Known Member
First Name
Dee
Joined
Dec 14, 2018
Threads
57
Messages
2,119
Reaction score
2,415
Location
The Netherlands
Vehicles
A lot
Second, in the dashboard it says "Reboot MMI":
screenshot_20220726-153754-png.png

But unfortunately that doesn't work.
Ok, I fixed it.
First you have to change the "view" (properties) of the tile:

Screenshot_20220805-120903~2.png


I changed "Text" into "Action PID" (no wonder I couldn't find it!...).
After that you can select [5F.MMI]Reboot Multimedia System from the list of sensors.
It now looks like this:

Screenshot_20220806-190832~2.png


I also changed the text to the correct name.
Now it works from the dashboard page. 👍🏻
 

 
Vivid Racing
Top