Connect App Authentication Error

dnanian

Well-Known Member
First Name
David
Joined
May 18, 2020
Messages
95
Reaction score
50
Location
Massachusetts
Vehicles
Taycan, Tesla Model S, BMW i3
Country flag
I really don't understand how deleting the app - which deletes its entire sandbox, and all its data - wouldn't work. I suppose it's possible that when you reinstalled it restored data from iCloud for that app...but it seems bizarre that you'd have to reset.

I'm a developer and have used iOS since before v1.0, and I don't think I've ever had to wipe the phone to get an app to work.
 
OP

Pjjameso

Active Member
First Name
Paul
Joined
Dec 5, 2019
Messages
37
Reaction score
16
Location
Great Falls
Vehicles
Panamera GTS
Country flag
  • Thread starter
  • Thread Starter
  • #17
I really don't understand how deleting the app - which deletes its entire sandbox, and all its data - wouldn't work. I suppose it's possible that when you reinstalled it restored data from iCloud for that app...but it seems bizarre that you'd have to reset.

I'm a developer and have used iOS since before v1.0, and I don't think I've ever had to wipe the phone to get an app to work.
I deleted the app, rebooted, backed up to iCloud, reset the phone, installed the app, checked that it worked, then did a restore, installed the app and low and behold it Did NOT work.
So then back to wiping phone and starting from scratch which did work, I don’t know what happened but truly a pita.
 

Gogs

Well-Known Member
First Name
Gordon
Joined
Dec 14, 2019
Messages
477
Reaction score
215
Location
Aberdeen, Scotland, UK
Vehicles
Taycan 4S - Soon, 911 4S, Range Rover Sport Hybrid
Country flag
I deleted the app, rebooted, backed up to iCloud, reset the phone, installed the app, checked that it worked, then did a restore, installed the app and low and behold it Did NOT work.
So then back to wiping phone and starting from scratch which did work, I don’t know what happened but truly a pita.
Very common with certain apps. My iPhone did the same with a banking app. The genius guys at Apple recommended the full reset and no restore. Must be a bad app that we had that must have written some code that conflicted with the Porsche app.
 

dnanian

Well-Known Member
First Name
David
Joined
May 18, 2020
Messages
95
Reaction score
50
Location
Massachusetts
Vehicles
Taycan, Tesla Model S, BMW i3
Country flag
I deleted the app, rebooted, backed up to iCloud, reset the phone, installed the app, checked that it worked, then did a restore, installed the app and low and behold it Did NOT work.
So then back to wiping phone and starting from scratch which did work, I don’t know what happened but truly a pita.
They must have put something in the keychain (or maybe in CloudKit) that was corrupt and have no way to reset it other than by wiping the device. Casts a shadow on the abilities of their iOS developers...
 

dnanian

Well-Known Member
First Name
David
Joined
May 18, 2020
Messages
95
Reaction score
50
Location
Massachusetts
Vehicles
Taycan, Tesla Model S, BMW i3
Country flag
I deleted the app, rebooted, backed up to iCloud, reset the phone, installed the app, checked that it worked, then did a restore, installed the app and low and behold it Did NOT work.
So then back to wiping phone and starting from scratch which did work, I don’t know what happened but truly a pita.
One other thing to mention here - sometimes if you have more than one app from the same vendor they could be sharing some entries. So, if you have Good to Know and Connect (etc) there might be an issue.

Also, deleted app keychain entries are supposed to be deleted...but it might be that they put some sort of bad certificate into the certificate store, or something like that. Regardless, they should handle this in the app, and not require users to wipe their phones - that's crazy. You may have data on the phone that isn't in other places, only in the backup, and if you can't restore that it's lost forever - because of their bug.
 

wmras

Active Member
First Name
Bill
Joined
Apr 6, 2020
Messages
26
Reaction score
21
Location
Oregon
Vehicles
GT4, Macan Turbo, Cayman SBE 987.18
Country flag
Very common with certain apps. My iPhone did the same with a banking app. The genius guys at Apple recommended the full reset and no restore. Must be a bad app that we had that must have written some code that conflicted with the Porsche app.
We have had similar problems with multiple applications using iPhones 10 & 11 Pro Max - mostly financial apps. The following has worked for us:
  • Delete the app
  • Restart phone
  • Turn off cellular or WIFI in settings, not control panel
    (only one on)
  • Install app
  • Login
Suspect the problem may be encryption related, but not certain. We have had more problems with cellular than WIFI.
 

glennkreisel

Well-Known Member
First Name
Glenn
Joined
Sep 27, 2019
Messages
58
Reaction score
19
Location
Missoula, MT
Vehicles
Tesla Model S, Tesla Roadster
Country flag
We have had similar problems with multiple applications using iPhones 10 & 11 Pro Max - mostly financial apps. The following has worked for us:
  • Delete the app
  • Restart phone
  • Turn off cellular or WIFI in settings, not control panel
    (only one on)
  • Install app
  • Login
Suspect the problem may be encryption related, but not certain. We have had more problems with cellular than WIFI.
Whoa that is insane! :-D I'm a long time iOS developer and never heard of anything like that. So curious. Won't have my Turbo for a month or so.
 

feye

Well-Known Member
Joined
Sep 16, 2019
Messages
309
Reaction score
193
Location
Asia
Vehicles
Audi A7, MS 90D, Taycan 4S+ order locked
Country flag
One other thing to mention here - sometimes if you have more than one app from the same vendor they could be sharing some entries. So, if you have Good to Know and Connect (etc) there might be an issue.

Also, deleted app keychain entries are supposed to be deleted...but it might be that they put some sort of bad certificate into the certificate store, or something like that. Regardless, they should handle this in the app, and not require users to wipe their phones - that's crazy. You may have data on the phone that isn't in other places, only in the backup, and if you can't restore that it's lost forever - because of their bug.
How do you know, it is "their" bug, and not a bug in apple's sandbox?
 

MissionC

Well-Known Member
Joined
Feb 15, 2019
Messages
119
Reaction score
94
Location
Boston
Vehicles
2011 911, Taycan 4S on order
Country flag
There was a recent issue with iOS 13.5 and Family Sharing that caused Apple to reissue a slightly updated version of many apps — you may have noticed a large number of app updates recently. Perhaps that issue affected the Porsche app?
 

dryii

Well-Known Member
First Name
Doug
Joined
Jan 30, 2020
Messages
315
Reaction score
218
Location
Orlando, FL
Vehicles
2020 Porsche Taycan 4S, 2018 Tesla Model 3, 2015 Porsche Macan Turbo
Country flag
I've found, during the past couple days, the Connect app to be pretty bad on Android, too. Having to log in EVERY TIME is a pain. It doesn't always connect. The app tells me Porsche can't talk to the car (which I hope with change when they enable the Taycan to connect to my home wifi). We'll see how I feel in a week or so. It's a bit disappointing, but I get a sense I won't use it much later on.
 

dnanian

Well-Known Member
First Name
David
Joined
May 18, 2020
Messages
95
Reaction score
50
Location
Massachusetts
Vehicles
Taycan, Tesla Model S, BMW i3
Country flag
How do you know, it is "their" bug, and not a bug in apple's sandbox?
From a user's perspective, it doesn't matter whose bug it is: as developers, it's our responsibility to work around issues we find. For example, my own product was hit with a bug in the latest macOS 10.15.5 update, and I have to work around their bug.

Asking users to fully rebuild their entire system from scratch, without the benefit of being able to restore, just isn't a fix. It's Porsche's responsibility to come up with a workaround that doesn't cause that level of hardship and data loss.
 

dryii

Well-Known Member
First Name
Doug
Joined
Jan 30, 2020
Messages
315
Reaction score
218
Location
Orlando, FL
Vehicles
2020 Porsche Taycan 4S, 2018 Tesla Model 3, 2015 Porsche Macan Turbo
Country flag
How do you know, it is "their" bug, and not a bug in apple's sandbox?
I would say it's a problem with the app because of all the reports of it working poorly on all devices, including my own Android phone.
 

Dave T

Well-Known Member
Joined
Jan 14, 2020
Messages
288
Reaction score
91
Location
Boston
Vehicles
BMW 550, Taycan Turbo (ordered)
Country flag
From a user's perspective, it doesn't matter whose bug it is: as developers, it's our responsibility to work around issues we find. For example, my own product was hit with a bug in the latest macOS 10.15.5 update, and I have to work around their bug.

Asking users to fully rebuild their entire system from scratch, without the benefit of being able to restore, just isn't a fix. It's Porsche's responsibility to come up with a workaround that doesn't cause that level of hardship and data loss.
I'm a developer as well, and I totally agree. The "workaround" of doing a complete reinstall is unacceptable, and frankly, bizarre. You just don't do that, regardless of the cause of the bug. I hope and expect that Porsche comes out with a real fix, assuming that they have developers still working on it. If they contracted out the development of the app and that company has moved on to other things, then I'm less hopeful...
 

Benjamin

Member
Joined
Apr 12, 2020
Messages
13
Reaction score
18
Location
Stuttgart
Vehicles
Twingo
Country flag
I've had my Taycan for a few weeks now and can say with great certainty that the apps are all total crap. If you use them on your iPhone, my iPad or my Android pixel, the apps will do half the job. They are simply useless. The only thing that usually works in everyday life is the web interface. I put this as a shortcut on my home screen.
 
OP

Pjjameso

Active Member
First Name
Paul
Joined
Dec 5, 2019
Messages
37
Reaction score
16
Location
Great Falls
Vehicles
Panamera GTS
Country flag
  • Thread starter
  • Thread Starter
  • #30
I'm a developer as well, and I totally agree. The "workaround" of doing a complete reinstall is unacceptable, and frankly, bizarre. You just don't do that, regardless of the cause of the bug. I hope and expect that Porsche comes out with a real fix, assuming that they have developers still working on it. If they contracted out the development of the app and that company has moved on to other things, then I'm less hopeful...
I wouldn't count on much from the connect group called them a week ago before I wiped the phone. Said they opened a ticket re the issue but still haven't heard back from them.
 



Top